Buckaroo Plaza: Potential delay in payouts (02-02-2026)

Incident Report for Buckaroo

Resolved

We have received confirmation that this issue has been resolved. All of yesterday's affected payouts will be received today.
Posted Feb 03, 2026 - 08:22 CET

Identified

Due to an external disruption at our processing bank, Buckaroo Plaza merchants may be experiencing a delay in today's payout. In such cases, we are expecting the payout to be received tomorrow. We are maintaining communication with our bank and will post updates as they become available.
Posted Feb 02, 2026 - 18:10 CET
This incident affected: Services & Apps (Payouts).