iDIN Unavailable

Incident Report for Buckaroo

Resolved

The issue with iDIN has been resolved and the service is operating normally.
Posted Mar 19, 2026 - 10:59 CET

Investigating

Since March 16th, iDIN has not been available. We are currently investigating the cause of this issue and working on a solution to restore availability as soon as possible.
Posted Mar 18, 2026 - 16:19 CET
This incident affected: Services & Apps (Smart Checkout).