Duplicate automated reports from MyBuckaroo portal

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 15:28 CEST

Identified

Since 00:00 CEST today, some merchants have been receiving the same automatic report several times, in some cases every minute. At 07:55 CEST we paused automatic report delivery, so no new duplicate reports are being created.

We have identified the cause and are working on a fix. Scheduled reports may be delayed until then, and a few duplicate emails still in the queue may yet arrive. Payment processing and payouts are not affected. We will post another update once automatic reporting is working normally again.
Posted Sep 23, 2026 - 09:20 CEST
This incident affected: Services & Apps (MyBuckaroo).