External service disruption: iDEAL ABN Amro

Incident Report for Buckaroo

Resolved

The issue has been resolved by ABN Amro
Posted Feb 09, 2026 - 19:57 CET

Identified

There is an issue with the iDEAL availability of ABN Amro.
Users could experience issues when paying with iDEAL.
We will provide updates as they become available.
Posted Feb 09, 2026 - 19:43 CET
This incident affected: Payment methods (iDEAL).