Scheduled maintenance – Buckaroo Payment Engine

Scheduled for Sep 28, 06:00 - 07:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 24, 2026 - 06:37 CEST

Scheduled

On Monday 28 September 2026 we will carry out a planned major upgrade of the Buckaroo Payment Engine (BPE). The maintenance window runs from 06:00 to 07:00 CEST.

Expected impact: We expect ECOM transactions to be unavailable for about 15 minutes, between 06:00 and 06:15 CEST. For the rest of the window, services should run normally. We have kept the remaining time as a safety margin. Payment attempts made while processing is paused may fail and can be retried once service has resumed.
We will post updates here when the maintenance starts and when it has finished.
Posted Sep 24, 2026 - 06:36 CEST
This scheduled maintenance affects: APIs (JSON, SOAP), Payment methods (iDEAL, Paypal, Bancontact, Mastercard, Visa, AMEX, Apple Pay, EPS, Belfius, Tinka, KBC Payment Button, iDEAL QR), Pay Later Services (Riverty, Klarna, In3, Billink), and Services & Apps (Plaza, Smart Checkout).